Currently we are not available by telephone
Incident Report for Paazl
Resolved
The issue has been solved. We are available again by telephone and by e-mail.
Posted Sep 20, 2017 - 13:23 CEST
Investigating
Currently we are not available by telephone. We are investigating the problem. We will post an update as soon as possible.
Posted Sep 20, 2017 - 12:42 CEST