Certificate update
Incident Report for Paazl
Resolved
We found the root of the problem and we will post a update schedule in a few minutes.
Posted May 11, 2018 - 16:12 CEST
Investigating
----Only applies to customers who save certificates locally----

There has been a rollback of the certificate update from Sunday evening. We will investigate what went wrong and update when we have more information.
Posted May 07, 2018 - 10:51 CEST