Delayed shipment registrations
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted Jul 27, 2017 - 11:34 CEST
Identified
Last weekend, we registered delayments in our preregistration of shipments. We have investigated the matter and implemented improvements.

If you have any questions about potential impact on your business, please contact support@paazl.com.
Posted Jul 25, 2017 - 14:32 CEST