Due to an issue at our provider we are currently only available by e-mail
Incident Report for Paazl
Resolved
The issue has been resolved. We are reachable by all standard channels.
Posted Sep 13, 2017 - 10:25 CEST
Identified
Due to an issue at our provider we are currently only available by e-mail

We will post an update as soon as possible.
Posted Sep 13, 2017 - 09:09 CEST