DHL Deutschland degraded performance
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted Feb 18, 2017 - 10:56 CET
Identified
The DHL Deutschland webservice is showing a degraded performance which may result in the inability to print DHL Deutschland shipping labels. We are awaiting performance improvement and advise you postpone printing untill the webservice at DHL Deutschland has returned to normal quality levels.
Posted Feb 17, 2017 - 21:43 CET