Staging environment: restart
Incident Report for Paazl
Resolved
Staging is back online again. We thank you for your patience
Posted Jan 12, 2018 - 11:40 CET
Investigating
We've performed a brief restart of our Staging service. We will be online again within a couple of minutes
Posted Jan 12, 2018 - 11:38 CET