ship.paazl.com: slow response time
Incident Report for Paazl
Resolved
The issue has been resolved.
Posted Mar 22, 2017 - 14:01 CET
Monitoring
The issue has been fixed. We are monitoring the situation closely.
Posted Mar 22, 2017 - 10:51 CET
Investigating
We are investigating reports of a slow response time on our live servers:
https://ship.paazl.com

We will update as soon as possible
Posted Mar 22, 2017 - 10:34 CET