Staging environment: performance update
Incident Report for Paazl
Resolved
The Staging environment is back to fully operational. We thank you for your patience.
Posted Mar 27, 2017 - 09:01 CEST
Investigating
We will be performing an update on our Staging environment. This will take till Monday morning.
Posted Mar 26, 2017 - 21:38 CEST