DHL DE label printing not possible
Incident Report for Paazl
Resolved
Printing labels is possible again.
Posted Mar 08, 2018 - 13:54 CET
Update
We are still investigating this issue with the highest priority.
Posted Mar 07, 2018 - 15:39 CET
Investigating
At this moment it is not possible to print shipping labels for DHL Deutschland. We are investigating the issue.
Posted Mar 07, 2018 - 13:43 CET