Correos Express: no response
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 17:17 CEST
Identified
Clients reported that they are unable to print shipping labels for Correos Express.

This is caused by an outage at Correos Express. Their website (https://www.correosexpress.com) has also been affected.

We are monitoring the situation.
Posted Apr 01, 2021 - 16:30 CEST
This incident affected: Correos.