Paazl available, office is closed
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted Jul 20, 2020 - 09:18 CEST
Identified
Because of the current situation surrounding the corona virus, our office is closed until further notice.

We are all working from home and doing our best to operate as usual. While you can still reach us by phone, we advise you to contact us by sending an e-mail to support@paazl.com for your regular questions.
Posted Mar 16, 2020 - 13:48 CET
This incident affected: Paazl (Paazl Office).