PostNL: connectivity issues
Incident Report for Paazl
Resolved
This incident has been resolved. PostNL service points are back online.
Posted May 06, 2021 - 09:34 CEST
Identified
PostNL is having connectivity issues. You may experience the following issues:
- Your checkout does not show any PostNL pick-up points


We are monitoring the situation. As soon as PostNL issues an update, we will follow up.
Posted May 05, 2021 - 13:42 CEST
This incident affected: PostNL.