DPD Parcel Shop Delivery unavailable
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted Feb 19, 2020 - 14:14 CET
Investigating
The shipping option Parcelshop Delivery is currently unavailable for Belgium. We are investigating the issue.
Posted Feb 03, 2020 - 11:58 CET
This incident affected: DPD (DPD Parcelshops).