Paazl Web Application: slow response
Incident Report for Paazl
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted May 14, 2020 - 12:30 CEST
Investigating
We are noticing that the response of our Web Application is slow.
Posted May 13, 2020 - 13:57 CEST
This incident affected: Paazl (Paazl Live Web Application).