DHL Label Update - Please check if all labels are still printed correctly
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted Jul 17, 2019 - 11:30 CEST
Monitoring
We did a necessary update on all our DHL labels. Together with DHL who approved the new labels. This should not effect the quality of the labels, only an improvement. To be sure: please, check your printed labels to see if everything still looks good.
Posted Jun 25, 2019 - 13:32 CEST
This incident affected: DHL (DHL Parcel Benelux, DHL Parcel (E-Commerce), DHL Express).