DHL Deutschland: offline
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted Nov 29, 2019 - 13:31 CET
Identified
The DHL Deutschland webservice is not responding. Because of this outage, you may experience issues when attempting to print shipping labels for this carrier. We've contacted DHL Deutschland and are awaiting a status update. This outage is not yet visible on their portal.

As soon as we receive an update, we will post it on this page. We thank you for your patience.
Posted Nov 29, 2019 - 13:22 CET
This incident affected: DHL (DHL Deutschland).