DPD Parcel Shop Delivery unavailable
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted May 17, 2019 - 09:04 CEST
Monitoring
We are noticing that the DPD Parcelshop webservice is available again. We will continue to monitor the situation.
Posted May 16, 2019 - 16:17 CEST
Update
DPD still does not know how long it will take to fix the issue. If you have questions, we advise you to contact your DPD account manager.
Posted May 16, 2019 - 14:57 CEST
Identified
Due to an outage at the DPD Parcelshop web service, the shipping option Parcelshop Delivery is unavailable.

DPD can't tell us when the issue will be fixed, so we will continue to monitor the situation.
Posted May 16, 2019 - 09:45 CEST
This incident affected: DPD (DPD Parcelshops).