Correos Express: We are not able to reach the server - Not able to print labels at the moment
Incident Report for Paazl
Resolved
We are able to reach the server of Correos again. Printing labels is possible again.
Posted May 16, 2018 - 09:53 CEST
Investigating
We are not able to reach the server of Correos. Not able to print labels at this moment. We contacted Correos to find out where the issue lies. As soon as we have more information about this issue we will update this incident.
Posted May 15, 2018 - 17:59 CEST