DPD webservice timeout
Incident Report for Paazl
Resolved
DPD has resolved the issue
Posted Jul 26, 2024 - 08:48 CEST
Identified
DPD is currently experiencing an issue which makes their services unavailable. The issue is on their side so we are awaiting updates.
Posted Jul 25, 2024 - 11:14 CEST
This incident affected: DPD (DPD Parcelshops, DPD Shipping Labels).