GLS label printing service outage
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 19, 2019 - 15:25 CEST
Monitoring
GLS informed us that the outage has been resolved.
Posted about 2 months ago. Aug 19, 2019 - 15:00 CEST
Investigating
Users are currently unable to print GLS labels. We are trying to contact GLS for more information.
Posted about 2 months ago. Aug 19, 2019 - 14:42 CEST
This incident affected: GLS.