Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 27, 2024 - 16:30 CET
Scheduled
We will be performing an update on our Staging environment. This will take around 30 minutes to finish.
This week's release contains the following improvements: Order page: - We improved the dropdown options for carriers that support Service Availability.
Weight icons for Germany: - We added the weight icons on our self-built labels with destination Germany for the carriers Generic Carrier and DHL Express DD.
Posted Nov 27, 2024 - 15:53 CET
This scheduled maintenance affected: Paazl (Paazl Staging Webservice, Paazl Staging Web Application).