Degraded Performance
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted Jan 15, 2022 - 11:38 CET
Investigating
We're experiencing possible downgraded performance with Packs. We are investigating the issue and will update the statuspage as soon as possible.
Posted Jan 14, 2022 - 19:21 CET
This incident affected: Packs.