DHL Deutschland: slow response
Incident Report for Paazl
Resolved
DHL's webservice is responding normally again. We will close this incident.
Posted May 18, 2020 - 11:47 CEST
Identified
The DHL Deutschland webservice is showing a delayed response. Because of this outage, you may experience issues when attempting to print shipping labels for this carrier.

As soon as we receive an update, we will post it on this page.
Posted May 18, 2020 - 08:50 CEST
This incident affected: DHL (DHL Deutschland).