DHL Ecommerce: Servicepoints unavailable
Incident Report for Paazl
Resolved
DHL has found and fixed the issue. Servicepoints are back online.
Posted about 1 month ago. Aug 17, 2019 - 18:32 CEST
Identified
DHL Ecommerce Servicepoints are unavailable. We've contacted DHL Parcel and are awaiting a response.

We advise you to temporarily deactivate DHL Ecommerce servicepoints in the Paazl Delivery Matrix until further notice.
Posted about 1 month ago. Aug 16, 2019 - 21:08 CEST
This incident affected: DHL (DHL Parcel (E-Commerce)).