WebApp (ship.paazl.com): instability
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted Oct 22, 2021 - 17:27 CEST
Investigating
You may experience some instability using our WebApp on ship.paazl.com. We are investigating the issue and will report back as soon as we have an update.
Posted Oct 22, 2021 - 11:08 CEST
This incident affected: Paazl (Paazl Live Web Application).