No shipping options in checkout
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted Oct 22, 2021 - 10:57 CEST
Monitoring
Everything should be back online again. We are monitoring the results.
Posted Oct 21, 2021 - 11:30 CEST
Investigating
We are currently investigating reports of checkouts that do not show any shipping options. We are looking into it with high priority and will report back as soon as possible.
Posted Oct 21, 2021 - 09:30 CEST
This incident affected: Paazl (Paazl Live Webservice).