Paazl Web Application: carrier history
Incident Report for Paazl
Resolved
Order history has returned properly.
Posted Oct 11, 2021 - 10:16 CEST
Investigating
We are noticing that carrier history for orders may not load properly in our Web Application.

This does not impact the labels, status updates (and subsequent PUSH and mail notifications), or API.
Posted Oct 05, 2021 - 14:27 CEST
This incident affected: Paazl (Paazl Live Web Application).