UPS: slow response web service
Incident Report for Paazl
Resolved
This incident has been resolved.
Posted Jul 20, 2020 - 09:16 CEST
Identified
Response times from the UPS web service have occasionally been slow today. You may experience long load times or web service time-outs when attempting to generate UPS shipping labels. We notified UPS on the matter.

Because we see that this issue is occurring intermittently, we advise you to try generating a shipping label again if it doesn't work the first time.
Posted Nov 30, 2019 - 19:04 CET
This incident affected: UPS.