UPS : Authentication

Incident Report for Paazl

Resolved

This incident has been resolved.
Posted Sep 14, 2023 - 10:42 CEST

Update

UPS has notified us that they are investigating the issue. We will post further updates as they arise.
Posted Sep 13, 2023 - 18:44 CEST

Identified

We have been notified that UPS is giving an Authentication error:
Unable to validate shipping order at UPS: (250002) Invalid Authentication Information

We have reached out to UPS for more information
Posted Sep 13, 2023 - 16:29 CEST
This incident affected: UPS.