DPD BE downtime

Incident Report for Paazl

Resolved

DPD BE has fixed the issue.
Posted Jun 24, 2025 - 13:27 CEST

Identified

DPD Belgium is currently experiencing downtime. We are awaiting their resolve.
Posted Jun 24, 2025 - 10:02 CEST
This incident affected: DPD (DPD Parcelshops, DPD Shipping Labels).